Platform Performance
Incident Report for ENGIE Impact
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 08:49 PST
Investigating
Platform performance is extremely slow and is under investigation.
Posted Nov 18, 2024 - 08:30 PST
This incident affected: ENGIE Platform (External).