Engie Impact Platform Unavailable

Incident Report for ENGIE Impact

Resolved

The issue has been identified and resolved. All users should be able to log into the platform at this time.
Posted Apr 03, 2025 - 13:19 PDT

Investigating

We are currently investigating the log in error users are receiving when attempting to log into the Engie Platform.
Posted Apr 03, 2025 - 12:12 PDT
This incident affected: ENGIE Platform (External).