Bill Images and Financial Files are not being displayed

Incident Report for ENGIE Impact

Resolved

This has been resolved. Please reach out to your Customer Success Representative if you are still having issues accessing bill images or financial files.
Posted Jul 06, 2026 - 09:23 PDT

Investigating

Users are receiving errors when trying to open bill images or financial files on the platform. Our teams are investigating this issue.
Posted Jul 06, 2026 - 07:06 PDT
This incident affected: ENGIE Platform (External).