Platform Manage User Section Unavailable

Incident Report for ENGIE Impact

Resolved

this has been resolved. If you are still experiencing issues with the User Management Screen please contact your Customer Success Representative.
Posted Aug 19, 2026 - 11:34 PDT

Investigating

Managing users is currently unavailable in the Platform. This is being investigated.
Posted Aug 19, 2026 - 09:44 PDT
This incident affected: ENGIE Platform (External).