Platform Password Reset Unavailable?
Incident Report for ENGIE Impact
Resolved
The email issue impacting Password resets have been resolved. Everything is now working as expected.
Posted Jan 16, 2025 - 15:17 PST
Investigating
At this time the password reset email function is unavailable for the Engie Impact Platform. We are currently investigating the issue.
Posted Jan 16, 2025 - 14:51 PST
This incident affected: ENGIE Platform (External).