Portfolio Benchmarking is Down
Incident Report for ENGIE Impact
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 08:06 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 18, 2023 - 13:43 PDT
Investigating
Reports are currently inaccessible for users who subscribe to Portfolio Benchmarking. Thumbnails show reports that exist, but the reports are not loading when you click on them. Our support team is actively investigating the issue and will provide an update as soon as possible.
Posted Sep 18, 2023 - 12:52 PDT
This incident affected: ENGIE Platform (External).