Engie Impact Platform Login and Page Navigation Issues

Incident Report for ENGIE Impact

Resolved

This has been resolved. Users should manually clear browser history prior to logging in. If you are still experiencing this issue, please reach out to your Client Success Representative.
Posted Apr 02, 2026 - 05:16 PDT

Identified

The issue has been identified, and a potential fix is being tested.
Posted Apr 01, 2026 - 17:07 PDT

Investigating

Some users are seeing an error when logging into the platform or navigating from page to page. We are currently investigating this issue. You may try to close the browser, open a new browser session, clear browser cache manually and log back in as this may resolve the issue while we are investigating.
Posted Apr 01, 2026 - 13:17 PDT
This incident affected: ENGIE Platform (External).