Engie Impact Platform Is Not Accessible

Incident Report for ENGIE Impact

Resolved

This has been resolved. If you are still experiencing issues, please contact your Client Success Representative.
Posted Jun 25, 2025 - 09:48 PDT

Monitoring

We believe this has been resolved but will continue to monitor for any further issues.
Posted Jun 25, 2025 - 07:27 PDT

Investigating

The platform is currently unavailable. We are investigating the cause and will resolve as soon as possible.
Posted Jun 25, 2025 - 06:24 PDT
This incident affected: ENGIE Platform (External).